RaspbmcCrystalbuntu

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspbmc: audio freaky poppin good :-(
12-23-2012, 01:28 PM
Post: #2
RE: Raspbmc: audio freaky poppin good :-(
(12-23-2012 12:04 PM)DisasterArea Wrote:  Hallo everybody,

this will be my first post in this forum and I hope I get help. My skills in Linux are not very well, but before I post some questions I first try to solve the problem by myself. But I give up now.

Yesterday I did my last try, to get this popping noise away when I run Raspbmc as just an audio interface. My goal is, to run RasPi mainly as a headless RasPi with no need to have the 300 Watt consuming TV switched on just to see which track is playing.
I want to control Audio via the Web Interface of Raspbmc or an App.

But: Forums are full with posts about popping sound each start/stop/ffwd of tracks.
Some say, they use pulseaudio with a usb sound device.
I don't want to use another power consuming device, when RasPi comes with a device at all.

I know, the first days, RasPi had problems with the analog output but with the current Wheezy Image I thing these days are gone. So why is it a problem in Raspbmc.

Yesterday, I tried to activate pulseaudio and module snd-bcm2835 as posted here but it says "Module not found". I did a apt-get update, apt-get install alsa-utils but no way to get this module. Where is the module?
I also tried to activate my ZOOM H2 audio recorder as a sound device vie SSH (PuTTY from a windows pc) and run in a access problem.
----------------------
pi@raspbmc:~$ sudo bash
root@raspbmc:/home/pi# pactl list cards
PuTTY X11 proxy: wrong authorisation protocol attemptedxcb_connection_has_error() returned true
Connection failure: Connection refused
pa_context_connect() failed: Connection refused
root@raspbmc:/home/pi#

---------------------

In the terminal window I had to enter 'ssh pi@raspbmx "pactl list cards"' instead of directly enter pactl list cards.
At the end, pulseaudio knows about the card and has this multi-sink profile set but no sound comes out as well.
The RaspBMC user interface says, that it does not find any sound device but pactl list the ZOOM H2. So I get totally stuckHuh.

Remember, I'm a newbie in Linux / Raspbmc and pulseaudio but I'm a .NET programmer and Oracle certified associate as well, so I know how to enter commands in a terminal Big Grin

So is it still usefull to try get RaspBMC analog audio output running or not?

And I guess: It is good to donate to this project and to Sam Nazarko but I also think, this project is to big for one person alone. A day has 24 hours and a students day has 24 hours as well with sleeping, eating, drinking, posting in forums, programming, testing, girl friend, go to a party

The ALSA module was temporarily deprecated due to faults. But this will be re-added shortly.

I saw your Putty session above, followed by an X11 failure. This is because Raspbmc does not utilise an X server.

Lastly, your analogue popping is likely XBMC. This was originally thought to be a firmware issue, but playing audio via the DAC directly did not yield this issue for most.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Raspbmc: audio freaky poppin good :-( - Sam Nazarko - 12-23-2012 01:28 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Sponsored Advertisement