RaspbmcCrystalbuntu

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RaspBMC Drive (not folder) sharing - Windows?
11-03-2012, 12:09 AM
Post: #1
RaspBMC Drive (not folder) sharing - Windows?
Hello all,

I've got the Rev B 512MB Pi with RaspBMC RC5 installed. ASUS N-10 wireless functioning fine with consistent connection.

I can stream videos from my W7x64 desktop to my Pi without any issue via the following method:

Videos > files > add videos > browse > set up new connection via "windows server" + my desktop's static IP + name of folder shared + no username and password > voila! Any files within that shared folder are now available to stream (permissions set to everyone - full access, with the security setting "anonymous equals everyone" set).

However, if I try to share the entire drive (not any one folder) containing ALL of my video folders && files (2TB+), RaspBMC cannot connect to it. I added it anyways despite the prompt, am prompted to enter the "Lock settings" twice (both fields empty, and "remember my settings" IS checked), and will receive the dreaded "Remote share - Could not connect to network server" error.

The drive, in this instance "Ocean", is noted as shared in properties > sharing. In advanced sharing (Windows), "Share this folder" is checked, and again Everyone is granted full access.


Is drive streaming not supported in RaspBMC like folder streaming is?



Thanks for the read.
Find all posts by this user
Quote this message in a reply
11-03-2012, 12:33 AM
Post: #2
RE: RaspBMC Drive (not folder) sharing - Windows?
Sounds like it should work. Are you joined to a Homegroup? Homegroup tends to play tricks with sharing and seems to override permissions. You could try adding it as a source in the xbmc file manager. You can also specify a username and password in your sources.xml see here http://wiki.xbmc.org/index.php?title=Sources.xml

Pi problems?? Start here http://forum.stmlabs.com/showthread.php?tid=3918
http://elinux.org/R-Pi_Troubleshooting
http://elinux.org/RPi_config.txt
Find all posts by this user
Quote this message in a reply
11-03-2012, 12:43 AM
Post: #3
RE: RaspBMC Drive (not folder) sharing - Windows?
(11-03-2012 12:33 AM)Dilligaf Wrote:  Sounds like it should work. Are you joined to a Homegroup? Homegroup tends to play tricks with sharing and seems to override permissions. You could try adding it as a source in the xbmc file manager. You can also specify a username and password in your sources.xml see here http://wiki.xbmc.org/index.php?title=Sources.xml

Thanks for the quick response.

There is no homegroup enabled. I hate that "feature". I am SSH'd into my Pi as we speak and am trying to find the "sources.xml" file. For what purpose would I provide a username and password, and would it be my windows user account username and password (eg. "Sherlock" "xxxx")?
Find all posts by this user
Quote this message in a reply
11-03-2012, 12:49 AM
Post: #4
RE: RaspBMC Drive (not folder) sharing - Windows?
/home/pi/.xbmc/userdata/sources.xml If there are no sources added yet it won't exist, you can add a couple of local folders as "fake" sources to get xbmc to create the file then edit them to point to your shares. Yes it would be your Windows credentials something like this

<source>
<name>TV</name>
<path pathversion="1">smb://username:password@192.168.1.123/Videos/</path>
</source>

Pi problems?? Start here http://forum.stmlabs.com/showthread.php?tid=3918
http://elinux.org/R-Pi_Troubleshooting
http://elinux.org/RPi_config.txt
Find all posts by this user
Quote this message in a reply
11-03-2012, 01:03 AM
Post: #5
RE: RaspBMC Drive (not folder) sharing - Windows?
I have found the file and transferred it to my desktop via FTP (not sure how to edit it via SSH). Inside sources.xml, I'm met with this:

<sources>
<programs>
<default pathversion="1"></default>
</programs>
<video>
<default pathversion="1"></default>
<source>
<name>Ocean</name>
<path pathversion="1">smb://192.168.1.101/Ocean/</path>
</source>
<source>
<name>atemp</name>
<path pathversion="1">smb://192.168.1.101/atemp/</path>
</source>
</video>
<music>
<default pathversion="1"></default>
</music>
<pictures>
<default pathversion="1"></default>
</pictures>
<files>
<default pathversion="1"></default>
</files>
</sources>


Now, "atemp" is the folder that connects and streams. Ocean (case-sensitive?) is that hard drive containing everything including "atemp" which does not connect or stream.

You're suggesting a change to:

<sources>
<programs>
<default pathversion="1"></default>
</programs>
<video>
<default pathversion="1"></default>
<source>
<name>Ocean</name>
<path pathversion="1">smb://Sherlock Holmes:mypassword@192.168.1.101/Ocean/</path>
</source>
<source>
<name>atemp</name>
<path pathversion="1">smb://192.168.1.101/atemp/</path>
</source>
</video>
<music>
<default pathversion="1"></default>
</music>
<pictures>
<default pathversion="1"></default>
</pictures>
<files>
<default pathversion="1"></default>
</files>
</sources>

correct? Sherlock Holmes has a space in it. Will the xml flip out if I don't use quotes? I'm not sure of the syntax.
Find all posts by this user
Quote this message in a reply
11-03-2012, 01:17 AM
Post: #6
RE: RaspBMC Drive (not folder) sharing - Windows?
Good question about the spaces. Being a long time linux user all my user_names, passwords, shares etc. do not contain spaces so I really don't know. I would think the opening and closing tags would work as quotes along with the : and @ Maybe someone else knows the answer to this.

Pi problems?? Start here http://forum.stmlabs.com/showthread.php?tid=3918
http://elinux.org/R-Pi_Troubleshooting
http://elinux.org/RPi_config.txt
Find all posts by this user
Quote this message in a reply
11-03-2012, 01:36 AM (This post was last modified: 11-03-2012 01:38 AM by BillPi.)
Post: #7
RE: RaspBMC Drive (not folder) sharing - Windows?
Update: The previously proposed configuration did not work, spaces or no spaces (tried "Sherlock Holmes" "SherlockHolmes" <Sherlock Holmes> and "Sherlock Holmes" <-- that one being the only one with included quotation marks). No luck.

For sh*ts and giggles I tried resetting back to original "sources.xml" that I started with (just IP and name, no username or password), and entering the username and password after double-clicking on Ocean within RaspBMC (lock settings). It remembered "Sherlock Holmes", but kept prompting me to enter my password after clicking OK. Only when I hit OK withOUT entering a password did I again receive the "could not connect..." error.

Interesting...

Edit: Sorry it takes so long to respond. My RaspBMC is so laggy I can't use the KB without a single key entry being repeated (eg. pppppppassword), and the mouse requires at least two clicks to register one click.
Find all posts by this user
Quote this message in a reply
11-03-2012, 02:09 AM
Post: #8
RE: RaspBMC Drive (not folder) sharing - Windows?
You could always make an xbmc account without spaces and try that. Not sure but it being Windows it may have some wonky rule about giving access to drive root, maybe requiring an account with a pasword.

The repeat keystrokes are a sure sign of low voltage, have a look at the power supply sticky.

Pi problems?? Start here http://forum.stmlabs.com/showthread.php?tid=3918
http://elinux.org/R-Pi_Troubleshooting
http://elinux.org/RPi_config.txt
Find all posts by this user
Quote this message in a reply
11-03-2012, 02:26 AM
Post: #9
RE: RaspBMC Drive (not folder) sharing - Windows?
Is there any reason you cannot just create a top-level folder on the drive, move all your video folders into that, then share that folder?
Find all posts by this user
Quote this message in a reply
11-03-2012, 02:32 AM
Post: #10
RE: RaspBMC Drive (not folder) sharing - Windows?
Also, if you're having usb problems then you're having network problems. They all share the 1 usb port on the chip.

Pi problems?? Start here http://forum.stmlabs.com/showthread.php?tid=3918
http://elinux.org/R-Pi_Troubleshooting
http://elinux.org/RPi_config.txt
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Sponsored Advertisement