RaspbmcCrystalbuntu

Post Reply 
 
Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Alpha] usb sound cards support for raspbmc
01-06-2013, 05:02 PM
Post: #341
RE: [Alpha] usb sound cards support for raspbmc
(01-05-2013 10:52 PM)chaosgenie Wrote:  Hi,

I got my PCM2704 working using the mplayer with a normal mp3-file.
But I could not get it to work with my brand new raspbmc-installation. I tried to activate AE but this ends up in an endless loop. I did not modify anything else.

Any hints or ideas?

Kind regards,
CG

I've got the same card, Mister Fab & 'forot-his-name' got the same cards.

Mister Fab got it 'working' by buying a hdmi capable receiver.

I'm currently using an max 40 Watt receiver, and the new receiver i found on the internet which is capable of HDMI inputs, consumes like 100 Watts's.

I have currently running a shuttle barebone computer with Mediaportal, this machine consumes about 60 Watt's. The reason i want the pi for my movies and series is cause of it's low consumption 3-5 Watt.

So i bought this PCM2704 chip, read this whole thread (!!) and found out it play's audio really nice. The sound quality is very good. For music / radio that is.

For movies, i got it once to work (with the pre-prepped sd card that this topic starter mentioned.)

But it auto update itself and i got stuck in the white wait screen loop.

Never the less, i've got it working with that sd image. But when playing an movie / tv show (x264, ac3) i found out it does some resampling. this cost so much load that the frame rate drops real bad.

So i installed the normal image again, and couldn't get pass-through to work.

What i want to know:
Which sound cards seem to work with 5.1 pass-through? My receiver is capable of DTS / AC3 streams, but the PCM2704 doesn't send them 1 on 1.

Still deciding whether i should buy a new receiver, or wait for an stable version of AudioEngine and buy a good usb card.

Any suggestions?
Find all posts by this user
Quote this message in a reply
01-07-2013, 02:37 PM
Post: #342
RE: [Alpha] usb sound cards support for raspbmc
(01-06-2013 05:02 PM)leroyz84 Wrote:  [...]
What i want to know:
Which sound cards seem to work with 5.1 pass-through? My receiver is capable of DTS / AC3 streams, but the PCM2704 doesn't send them 1 on 1.
[...]
I have Turtle Beach Audio Advantage Micro II, it definitely works with passthrough at the OS level.
With rasbmc I recently tried some nightly build from december with the following results with passthrough:
- A/V ac3 5.1 - downmixed to stereo
- A/V dts - no sound
- Audio only ac3 - downmixed to stereo
- Audio only dts 4.0 - plays with short breaks (sync) every few seconds

Thus the hardware is fine and I can recommend it. However I believe some more time is needed for developers to get it working right.
Find all posts by this user
Quote this message in a reply
01-09-2013, 03:20 PM (This post was last modified: 01-09-2013 04:01 PM by chaosgenie.)
Post: #343
RE: [Alpha] usb sound cards support for raspbmc
HDMI receiver would be a solution, but too expensive at the moment.

So, any other ideas how to get it working?
Why is my raspbmc looping when I enable "Audio engine"? I activated HDMI in the raspbmc-Audio-Setup.

Cheers
Find all posts by this user
Quote this message in a reply
01-09-2013, 04:59 PM
Post: #344
RE: [Alpha] usb sound cards support for raspbmc
I am currently using the latest nightly with a Cambridge Audio DacMagic. With AudioEngine enabled, and downmix to stereo, I get sound through USB. The problem I have is that whenever the CPU is loaded (even when just moving around in the menu), I get crackles and interruptions in sound output. Also, sound is NEVER synced to video, right from the start of the video; usually it's off by about a second or so. My question is whether these are normal issues or if there is something I can do to mitigate some of the problems.

Cheers.
Find all posts by this user
Quote this message in a reply
01-09-2013, 05:02 PM
Post: #345
RE: [Alpha] usb sound cards support for raspbmc
I also have these delays after installing alsa-audio over the analog output.
Find all posts by this user
Quote this message in a reply
01-09-2013, 07:22 PM
Post: #346
RE: [Alpha] usb sound cards support for raspbmc
@ all

video/audio sync is not supported yet
Find all posts by this user
Quote this message in a reply
01-10-2013, 12:22 AM
Post: #347
RE: [Alpha] usb sound cards support for raspbmc
(01-09-2013 04:59 PM)opt-e Wrote:  I am currently using the latest nightly with a Cambridge Audio DacMagic. With AudioEngine enabled, and downmix to stereo, I get sound through USB. The problem I have is that whenever the CPU is loaded (even when just moving around in the menu), I get crackles and interruptions in sound output. Also, sound is NEVER synced to video, right from the start of the video; usually it's off by about a second or so. My question is whether these are normal issues or if there is something I can do to mitigate some of the problems.

Cheers.

I am usinng the same setup with the Cambridge Audio DacMagic via usb and i have exactly the same problems. Interestingly, everthing worked fine with the beta 3 version of raspbmc, inclouding pluse audio 2.1, and a nightly from 20121219. Perhaps anyone can give us a hint how to install the respective old version?
Find all posts by this user
Quote this message in a reply
01-10-2013, 05:53 PM
Post: #348
RE: [Alpha] usb sound cards support for raspbmc
(01-09-2013 07:22 PM)SüßeSahne Wrote:  @ all

video/audio sync is not supported yet

Thanks for that information. Any idea when it will be supported?
Find all posts by this user
Quote this message in a reply
01-11-2013, 12:00 PM (This post was last modified: 01-11-2013 12:02 PM by bugada.)
Post: #349
RE: [Alpha] usb sound cards support for raspbmc
I've connected the PI to a ToppingTP30 to use its internal DAC. Then I've enabled audioengine to use external USB dac.

When playing music the cpu goes to 100% (76% xbmc, 19% pulseaudio) and the gui is unusable (delay,popping etc)
But the worst thing is that if I use the paplayer, the system crashes at the start of the second song of the playlist, if I use omxplayer everithing is ok.
Randomly with omxplayer, a song continue to infinite (no sound but counter increasing).

If you need further infos to investigate tell me what log I have to provide.

Thank you.
Andrea
Find all posts by this user
Quote this message in a reply
01-11-2013, 01:22 PM
Post: #350
RE: [Alpha] usb sound cards support for raspbmc
I have exactly the same problem with dr. DAC nano. What's more omxplayer can't play same flac files Huh
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)

Sponsored Advertisement